Bug (ancien d'ailleurs il me semble ;)) dans les liens hypertextes sur le forum - Page 1 - Sujet de discussion

Bug (ancien d'ailleurs il me semble ;)) dans les liens hypertextes sur le forum

Dernier message
Portrait de Nival
Inscrit le : 23/10/2013
Commentaires : 778
Messages : 1677

Salut,

Il y a un bug sur les liens hypertextes dans le forum lorsqu’on utilise dans son message la formulation raccourcie :
[ URL ] adresse du lien [ /URL ].
Dans ce cas le lien ne renvoie non pas vers l'adresse inscrite mais vers la page du forum où l'on est déjà.

Cela oblige à utiliser la syntaxe longue :
[ URL=adresse du lien ] texte (qui peut être l'adresse du lien, ou tout ce que l'on veut) [ /URL ]

(exemples dans ce post : https://www.indiemag.fr/forum/entre-developpeurs-joueurs/t6842-action-arcade-shooty-tank)

8 commentaires
Administrateur
Portrait de Seldell
Inscrit le : 10/07/2013
Commentaires : 1437
Messages : 616
Message Sujet: Re: Bug (ancien d'ailleurs il me semble ;)) dans les liens hypertextes sur le forum     05/04/2016 à 19:34

J'essaye de regarder ça vite. Content

Merci pour le signalement.

Trop de stress pour un si petit renard.

Portrait de Nival
Inscrit le : 23/10/2013
Commentaires : 778
Messages : 1677
Message Sujet: Re: Bug (ancien d'ailleurs il me semble ;)) dans les liens hypertextes sur le forum     17/11/2016 à 18:40

'lut, juste pour signaler que le bug existe toujours Tire la langue
(pose p.ex. problème ici : https://www.indiemag.fr/forum/entre-developpeurs-joueurs/t8461-robonauts-pc-mac-ps4-lire-vos-reactionsquestions-demo)

Administrateur
Portrait de Seldell
Inscrit le : 10/07/2013
Commentaires : 1437
Messages : 616
Message Sujet: Re: Bug (ancien d'ailleurs il me semble ;)) dans les liens hypertextes sur le forum     17/11/2016 à 22:45

Problème réglé. J'ai lutté 2h je crois. Tire la langue

Trop de stress pour un si petit renard.

Portrait de Nival
Inscrit le : 23/10/2013
Commentaires : 778
Messages : 1677
Message Sujet: Re: Bug (ancien d'ailleurs il me semble ;)) dans les liens hypertextes sur le forum     17/11/2016 à 23:17

Bien ouèj, ça fonctionne bien ! Clin d'oeil

Portrait de Nival
Inscrit le : 23/10/2013
Commentaires : 778
Messages : 1677
Message Sujet: Re: Bug (ancien d'ailleurs il me semble ;)) dans les liens hypertextes sur le forum     27/11/2020 à 11:59

'lut Seldell, ça remarche pas Mort .

Et ce coup-ci, d'aucune manière, j'ai vu ça sur la page ici :
https://www.indiemag.fr/forum/lactu-inde-reagissez/t15968-kickstarter-spiriton-est-ligne#comment-45571

En fait, comme tu peux le constater en cliquant, ça marche pour les liens internes au site, mais pour les liens qui pointent vers l'extérieur, non, comme donc pour le lien vers le Kickstarter pointé dans ce topic.

Et ce coup-ci, ça ne marche ni en simplifié
[url]www.kickstarter.com/projects/spiriton/spiriton-monster-catcher-rogue-lite-rpg[/url]
(www.kickstarter.com/projects/spiriton/spiriton-monster-catcher-rogue-lite-rpg)
ni en explicite
[url=www.kickstarter.com/projects/spiriton/spiriton-monster-catcher-rogue-lite-rpg]www.kickstarter.com/projects/spiriton/spiriton-monster-catcher-rogue-lite-rpg[/url]
(www.kickstarter.com/projects/spiriton/spiriton-monster-catcher-rogue-lite-rpg)
(Ça intercale comme avant l'URL de la page indiemag où on se situe en amont de l'URL cible.)

EDIT :
En fait je crois que c'est un pb d'"http://" manquant, non ?
http://www.kickstarter.com/projects/spiriton/spiriton-monster-catcher-rogue-lite-rpg
Ah oui c'est ça ! (ça reste un bug quand même il me semble :P)

Administrateur
Portrait de Seldell
Inscrit le : 10/07/2013
Commentaires : 1437
Messages : 616
Message Sujet: Re: Bug (ancien d'ailleurs il me semble ;)) dans les liens hypertextes sur le forum     04/12/2020 à 11:29

J'avais raté ton message, désolé. Oui c'est le http le problème effectivement. Pour les numéros de pages il faut que je regarde pourquoi ça a sauté >_<

Trop de stress pour un si petit renard.

Administrateur
Portrait de Seldell
Inscrit le : 10/07/2013
Commentaires : 1437
Messages : 616
Message Sujet: Re: Bug (ancien d'ailleurs il me semble ;)) dans les liens hypertextes sur le forum     04/12/2020 à 14:16

C'est réglé pour le raccourci vers le commentaire. Pour une raison inconnue, le nombre était écrit à l'anglaise avec une virgule séparatrice des milliers. Pour le lien avec www, c'est un problème inhérent au web. Si ça démarre par www, le lien ne peut pas marcher. Il faut indiquer le protocole pour que ce soit un lien externe. J'ai regardé le BBCode, il devrait remplacer un lien qui démarrant avec www par https://www mais étrangement il ne l'a pas fait ici. Je ne comprends pas pourquoi. Il faudrait que j'étudie davantage le problème. 

Trop de stress pour un si petit renard.

Portrait de Nival
Inscrit le : 23/10/2013
Commentaires : 778
Messages : 1677
Message Sujet: Re: Bug (ancien d'ailleurs il me semble ;)) dans les liens hypertextes sur le forum     07/12/2020 à 17:26

Ah oui, cool pour cette correction qui est très bienvenue ! Joyeux
Pour le "http://" qui ne s'insère pas automatiquement en cas d'oubli, bah, d'ici là suffit de le savoir et de s'y adapter.